NASCAR - Pit Stop Clips Are Not Loading to ProPenalty Site. – Incident details
Report an issue
Get updates
Email
Slack
Microsoft Teams
Google Chat
Webhook
RSS
Atom
API
Report an issue
Get updates
Dark mode
Team Analytics On-Demand experiencing partial outage
Pit Stop Clips Are Not Loading to ProPenalty Site.
Resolved
Degraded performance
Started 4 months ago
Lasted 31 minutes
Affected
Websites
Degraded performance from 1:36 AM to 2:07 AM
Pro Penalty
Degraded performance from 1:36 AM to 2:07 AM
Updates
Resolved
November 01, 2025 at 2:07 AM
Resolved
November 01, 2025 at 2:07 AM
This incident has been resolved.
Investigating
November 01, 2025 at 1:36 AM
Investigating
November 01, 2025 at 1:36 AM
We are currently investigating this incident.